通达信杰出智能买卖系统成套公式破解原码

来源:百度文库 编辑:16楼社区 时间:2019/10/24 05:53:33
? 通达信杰出智能买卖系统成套公式破解原码:
首先要感谢原作者提供这么好的公式原码,真诚的说一声谢谢!
杰出智能系统,将葛南维法则完全程序化,盘中及时提示主力介入杰出智能系统,将葛南维法则完全程序化,盘中及时提示主力介入、顶部卖出、回调买入、抄底、反弹卖出,熊市降低套牢风险,牛市最大化波段收益!



葛南维八大法则
  
  在移动平均线中,美国投资专家葛南维(jogepsb ganvle)创造的八项法则可谓其中的精华,历来的平均线使用者无不视其为技术分析中的至宝,而移动平均线也因为它,淋漓尽致地发挥了道·琼斯理论的精神所在。 八大法则中的四条是用来研判买进时机,四条是研判卖出时机。总的来说,移动平均线在股价之下,而且又呈上升趋势时是买进时机,反之,平均线在股价线之上,又呈下降趋势时则是卖出时机。
  
  首先看买进时机。
  
  买1,平均线经过一路下滑后,逐渐转为平滑,并有抬头向上的迹象。别外,股价线也转而上升,并自下方突破了移动平均线,这是第一个买进讯号。
  
  买2,股介线开始仍在移动平均线之上,但呈急剧下跌趋势,在跌破移动平均线后,忽而转头向上,并自下方突破了移动平均线,这是第二个买进讯号。
  
  买3,与买2类似,但股价线尚未跌破移动平均线,只要移动平均线依然呈上升趋势,前者也转跌为升,这是第三个买进讯号。
  
  买4,股价线与移动平均线都在下降,问题在于股价线狠狠下挫,远离了移动平均线,表明反弹指日可待,这第4个买进讯号甚为许多短线客喜爱(所谓抢谷底),但切忌不可恋战,因为大势依然不妙,久战势必套牢。
葛南维的四条卖出法则,与买进的四条法则是一一对应的。
  
  卖1,移动平均线从上升转为平缓,并有转下趋势,而股价线也从其上方下落,跌破了移动平均线,这是第一个卖出讯号。
  
  卖2,股价线和移动平均线均很令人失望地下滑,这时股价线自下方上升,并突破了仍在下落的移动平均线后,又掉头下落,这是第二个卖出讯号。
  
  卖3类似卖2,问题是稍现反弹的股价线更加软弱,刚想突破移动平均线却无力突破,这是第三个卖出讯号。要注意的是卖3与买1不同,买1是移动平均线自跌转平,并有升迹象,而卖3,平均线尚处下滑之中。
  
  卖4,则股价一路暴涨,远远超过了虽也在上升的移动平均线,暴涨之后必有暴跌,所以此处是第四个卖出讯号,以防止暴跌带来的不必要的损失。   经过长期应用后,我们发现,平均线转跌为平,并有向上趋势,股价从平均线下方突破平均线,并始终大致保持在移动平均线之上方,这一段是牛市;而反之,平均线转升为平,并随后下跌,股价线从平均线上方突破平均线之下方,这一段便是熊市了。
  至于买4和卖4,怎样才算远离移动平均线,何时为适度,这就是乖离率的研究对象了。

智能买卖系统用法:
下午2:30分后建议打开预警系统!
1.指数短趋势上升阶段可全仓操作,指数短趋势下降阶段半仓操作!
2.个股短趋势上升阶段可全仓操作(指数也是上升阶段,否则半仓为宜);个股短趋势下降阶段半仓操作;
3.杰出智能系统中买指令含义:抄底-阶段性底部,可适当买入(风险较小);反弹-下跌途中的反弹,适宜短线博反弹(风险较大);买入-上升途中的洗盘回调,可全仓买入(风险很小);
4.杰出智能系统中卖指令含义:减仓-上升遇到一定阻力,宜减少仓位,若成交量减小,则有可能是上升途中的洗盘;卖出-上升遇到强阻力,宜清仓;危险-指高位盘旋后即将下跌信号,宜清仓,放量-一般建议清仓观望;
5.主力介入:指主力介入的信号,量能急剧放大,可考虑立即追涨,也可考虑回调后买入,须防止主力拉高出货(注:主力包括机构、大户、私募等);能买卖系统用法:





杰出智能买卖系统

{请一定要学习葛南维法则的精髓,才能够合理使用该指标,通达信适用}
短趋势线:MA(CLOSE,13),COLORRED,LINETHICK3;
中线:=MA(CLOSE,33),LINETHICK1;
中趋势线:MA(CLOSE,55),LINETHICK1,COLORGRAY;
年线:MA(CLOSE,250),LINETHICK1,COLORLIGRAY,POINTDOT;

涨:IF(短趋势线>REF(短趋势线,1),短趋势线,DRAWNULL),COLORRED,LINETHICK3;
平:=IF(短趋势线=REF(短趋势线,1),短趋势线,DRAWNULL),COLOR00FFFF,LINETHICK3;
跌:IF(短趋势线<>

上极限:=((C-REF(MA(CLOSE,20),1))/20+短趋势线)*1.20;
DRAWTEXT(CROSS(CLOSE,上极限),H*1.02,'减仓'),COLORGREEN;
DRAWTEXT(CROSS(CLOSE,MA(C,13)) AND 短趋势线<中趋势线>

DRAWTEXT(CROSS(短趋势线,C) AND INDEXC>MA(INDEXC,13) AND 短趋势线>REF(短趋势线 ,1) AND V中趋势线 ,L*0.97,'买入'),COLORRED;
STICKLINE(CROSS(短趋势线,C) AND 短趋势线>REF(短趋势线 ,1) AND V中趋势线 ,L,L*0.99,2,0),COLORYELLOW;

VAR1:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100)/3;
DRAWTEXT(VAR1>9 AND V<>
DRAWTEXT(VAR1>9 AND V>REF(V,1) AND FILTER(VAR1<>
DRAWTEXT(VAR1>20 AND FILTER(VAR1<>

VAR2:=HHV(VAR1>20,10);
DRAWTEXT(FILTER(VAR1<-9 AND VAR1>REF(VAR1,1),18) AND V>REF(V,1),L*0.98,'反弹'),COLORRED;
DRAWTEXT(VAR1<-20 AND FILTER(VAR1> REF(VAR1,1),5),L*0.95,'抄底'),COLORYELLOW;
DRAWTEXT(VAR2 AND CROSS((REF(HIGH,1)+REF(LOW,1))/2,MA(CLOSE,20)+2*STD(CLOSE,20)),H*1.1,'危险'),COLORYELLOW;


VAR12:=(HIGH - LOW);
VAR3:=ABS((OPEN - CLOSE));
VAR4:=(HIGH - IF((CLOSE > OPEN),CLOSE,OPEN));
VAR5:=(IF((CLOSE > OPEN),OPEN,CLOSE) - LOW);
VAR6:=((VAR3 / VAR12) * VOL);
VAR7:=((VAR4 / VAR12) * VOL);
VAR8:=((VAR5 / VAR12) * VOL);
VARB:=(((MA(CLOSE,5) > MA(CLOSE,10)) AND (MA(CLOSE,10) > MA(CLOSE,30))) AND (MA(CLOSE,30) > MA(CLOSE,60)));
VARA:=(((CLOSE - MA(CLOSE,5)) / MA(CLOSE,5)) * 100);
DRAWTEXT((((((VAR6 > (MA(VOL,5) * 2)) AND 短趋势线>REF(短趋势线 ,1) AND (VAR6 >= VAR7)) AND (VAR6 >= VAR8)) AND (CLOSE > OPEN)) OR ((VOL > (MA(VOL,5) * 3)) AND VARB)) ,L*0.98,'主力介入'),COLORMAGENTA;

年线:=MA(C,250);
涨幅:=C/O>1.09;
DRAWTEXT(涨幅 AND FILTER(涨幅>REF(涨幅,1),10),REF(年线,20),'杰出智能系统指标用法注释有详细的使用说明'),COLORYELLOW;

DDX:

虚拟量:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL),NODRAW,COLOR669900;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,虚拟量,0,3,-1),COLOR00C0C0;
VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
成交:VOL,POINTDOT;
主动买盘:IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE
主动卖盘:=IF(CLOSE>OPEN,0-VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE
STICKLINE(VOL>0,VOL,0,3,1),COLORWHITE;
STICKLINE(主动买盘>0,0,主动买盘,3,0),COLORRED;
DDX:主动买盘+主动卖盘,COLORYELLOW;


下面是五个选股公式,也就是预警里面要用到的公式:
回调买入:

VAR1:CROSS(MA(C,13),C) AND MA(C,13)>REF(MA(C,13) ,1) AND INDEXC>MA(INDEXC,13) AND MA(C,13)>MA(C,55) AND V<>

反弹卖出:

短趋势线:=MA(C,13);
中趋势线:=MA(C,55);

FANTAN:CROSS(CLOSE,MA(C,13)) AND 短趋势线<>


顶部卖出:
VAR1:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100)/3;
MAICHU:VAR1>20 AND FILTER(VAR1<>


底部买入:
VAR1:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100)/3;
MAIRU:VAR1<-20 AND INDEXC REF(VAR1,1),5);


主力介入:
VAR12:=(HIGH - LOW);
VAR3:=ABS((OPEN - CLOSE));
VAR4:=(HIGH - IF((CLOSE > OPEN),CLOSE,OPEN));
VAR5:=(IF((CLOSE > OPEN),OPEN,CLOSE) - LOW);
VAR6:=((VAR3 / VAR12) * VOL);
VAR7:=((VAR4 / VAR12) * VOL);
VAR8:=((VAR5 / VAR12) * VOL);
VARB:=(((MA(CLOSE,5) > MA(CLOSE,10)) AND (MA(CLOSE,10) > MA(CLOSE,30))) AND (MA(CLOSE,30) > MA(CLOSE,60)));
短趋势线:=MA(C,13);
ZHULI:(((((VAR6 > (MA(VOL,5) * 2)) AND 短趋势线>REF(短趋势线 ,1) AND (VAR6 >= VAR7)) AND (VAR6 >= VAR8)) AND (CLOSE > OPEN)) OR ((VOL > (MA(VOL,5) * 3)) AND VARB AND 短趋势线>REF(短趋势线 ,1)));